Home Services Support Technologies Contact
 

 

Code 'n' Sprox
is not only the perfect tool for creating Insert or Update Stored Procedures and then creating the C# or VB.Net code to use them, it's the best tool in the universe in its class.

No longer do you need to use Management Studio, create Insert/Update statements from the table, create a Stored Procedure template, clean it up, and then copy/paste the statements into the template, and do your final cleanup. With one tool, you can create your Stored Procedures directly from the table. Then, you can customize the statement itself (only if you need it, of course) - not the whole structure.

And then, you can create Insert, Update, Select and Delete procedures based on that table in either C# and VB.Net with all the flexibility you had creating the Stored Procedure.

All this functionality is combined in one compact application!

Features

  Create Insert and Update Stored Procedures directly from the Table to which it's tied.
Run the Create Stored Procedure command and insert the Stored Procedure into the database.
Create the C# or VB.Net code for a method, to use the newly created Stored Procedures
Select your needed server from all the local network servers.
All you do is to connect to your Local or Hosted SQL Server Server and database and create what you need directly from your own data.
But that's not all - now, starting with version 2.0, you can also create classes with properties based on the columns from your table!

*** Version 3.1 Now Released!

ScreenShots

See Version Changes

Download 30 day trial today!

We're so confident that you will quickly find Code 'n' Sprox an indispensible tool, that we're offering a full 30 day trial download. In that time, you will be able to work with an unlimited amount of code.
Download Code 'n' Sprox Trial Locally  (about 9mb)


Get it from CNET Download.com!

Pricing

  Single License $79
  Site License $599

Purchase

Click here to purchase Code 'n' Sprox.
All major credit cards plus PayPal™ are accepted.

Minimum Requirements

Must have .Net version 4.0 or later installed.